Responder
Necesito ayuda para ostrar imagenes con php
Haz clic para ver el perfil del usuario

Usuario Novato
Usuario Novato

#1

He creado una funcion:
function mostrar($ini,$fin)
{
echo "<table width='80%' height='5%' cellpading='5' cellspacing='0' border='0' align='center' font='verdana' size='14' >
<tr>";
for($i=$ini;$i<$fin;$i++)
echo "<td width='20%' height='5%' colspan='3' align='center' ><a href ='ver.php?num=$i' ><img src='img_F/f".$i.".jpg' width='150' border='0'><br>".$i."</a></td>";
echo "</tr>";
echo "</table>";
}
que llama a otra

function ver($num)
{
echo "<table width='100%' cellpading='5' cellspacing='0' border='0' >
<tr>
<td colspan='3' align='center' ><img src='img_F/f".$num.".jpg'</td>
<td colspan='3' align='center' ></td>
</tr>
</table>";
}

en mi casa va perfecto pero cuando lo subo al hosting gratuito de miarroba no funciona, no se caul es el problema, a ver si me podeis ayudar.

Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#2

Creo que el problema es el $num de la línea

<img src='img_F/f".$num.".jpg'

Cámbiala por

<img src='img_F/f".$_GET['num'].".jpg'

a ver si va

Saludos.

PD Yambién deberías cerrar el tag con un >

ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Opciones:
Suscribir

Permisos:

TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 23:50 UTC+01:00
Ir al subforo:
Temas similares
TemaUsuariosRespuestasVisitasActividad
1985Apr/11
1872Nov/09
12kJun/09
1941Feb/09
22kNov/08