Versión imprimible del tema: Error en compartir artículos por Facebook
URL: https://soporte.miarroba.es/582513/11217173-error-en-compartir-articulos-por-facebook/

De la comunidad de foros: Foro de soporte
URL: https://soporte.miarroba.es


Autor: Raul_Tinoco, 27/Nov/2013, 23:01


Hola, buenas. Desde que superé los 100 articulos en mi blog: http://raultinoco.blogcindario.com no funciona el botón de compartir en Facebook, o comparte solo texto sin imagén o comparte un error 404.

Curiosamente si funciona si te vas a algún articulo antiguo, pero dejó de funcionar despues, en los últimos articulos.

¿Se puede hacer algo al respecto?


Autor: Tito, 28/Nov/2013, 08:59


@Raul_Tinoco, ¿qué boton de compartir en Facebook? ¿el de la barra de la barra de herramientas?


Autor: Raul_Tinoco, 28/Nov/2013, 09:55


Exacto, el que aparece en la barra miarroba. No he he visto otro.


Autor: Tito, 28/Nov/2013, 10:01


Pero ese botón lo que hace es compartir el enlace sin más ¿no?

¿Puedes darme un ejemplo de artículo para cada caso? (la dirección de uno que se comparte mal y uno bien)


Autor: Raul_Tinoco, 28/Nov/2013, 10:04


Escrito originalmente por @Tito

Pero ese botón lo que hace es compartir el enlace sin más ¿no?

¿Puedes darme un ejemplo de artículo para cada caso? (la dirección de uno que se comparte mal y uno bien)

Se comparte mal: https://raultinoco.blogcindario.com/[....]s-iii-estudio-trabajos-propios.html

Se comparte perfectamente: https://raultinoco.blogcindario.com/[....]nglaterra-descubriendo-autores.html

¿Esos te valen?


Autor: Tito, 28/Nov/2013, 10:20


@Raul_Tinoco, pues sí, ya veo el problema, lo investigo un poco a ver que saco en claro...


Autor: Raul_Tinoco, 28/Nov/2013, 10:25


Primeramente perdón por el doble post, pero me acabo de dar cuenta que quizá este detalle sería importante:

- Al compartir los últimos articulos cambia el enlace supongo que por uno que también lleva, pero que no es el correcto para la visualización de imagenes en la opción de compartir.

Ejemplo: https://raultinoco.blogcindario.com/[....]s-iii-estudio-trabajos-propios.html lo traduce como https://raultinoco.blogcindario.com/2013/11/00118.html, también lleva, pero en este enlace no deja ver las imagenes cuando compartes para Facebook.

Es decir, es un "Compartir" acompañado de una imagén del articulo lo que deberia salir como en articulos anteriores.


Autor: Raul_Tinoco, 28/Nov/2013, 10:25


Escrito originalmente por @Tito

@Raul_Tinoco, pues sí, ya veo el problema, lo investigo un poco a ver que saco en claro...

Gracias. Ahora si, perdon por el doble post.


Autor: Tito, 28/Nov/2013, 11:19


@Raul_Tinoco, solucionado.


Autor: Raul_Tinoco, 28/Nov/2013, 11:59


Con el articulo anterior al último no funciona.

https://raultinoco.blogcindario.com/[....]o-badajoz-descubriendo-autores.html

Intento copmpartirlo y no sale, sin embargo con el último si que funciona.

Y con los anteriores según voy comprobando si funciona.

Sí, creo que quizás es cosa del cache del navegador, pruebo y te digo.


Autor: Raul_Tinoco, 28/Nov/2013, 12:03


Muchas gracias, que no funcione con un articulo no me preocupa si ya funciona con el resto.

He probado y no sé porque con ese articulo no funciona.

He borrado el cache despues de actualizar el Blog y con ese articulo no hay forma.

¿Debería funcionar en todos?


Autor: Tito, 28/Nov/2013, 12:17


Eso es porque está todavía en el caché propio de facebook y no mira los nuevos cambios. El prímero funciona porque he forzado a que facebook lo lea nuevamente (no se cada cuanto lo renueva)

Le he forzado y ya debería de funcionar también.


Autor: Raul_Tinoco, 28/Nov/2013, 12:22


Ya funciona perfectamente, gracias. En serio, muchas gracias.


Autor: Raul_Tinoco, 17/Mar/2014, 13:47


Con el nuevo Facebook vuelve a fallar lo de compartir de Facebook.

https://raultinoco.blogcindario.com/[....]ncracios-2014-trabajos-propios.html

(Intento compartir ese articulo y no solo no me sale imagen, me sale que el blog no existe, aunque el link de arriba funcione)


Autor: Tito, 17/Mar/2014, 15:24


@Raul_Tinoco ¿has eliminado ese artículo para hacerlo nuevamente? En este momento lo que ves en facebook es que el artículo no existe (está cacheado)

Si no quieres esperar a que limpien ese cache tendrás que hacer alguna modificación en el título del artículo para que así cambie la URL.


Autor: Raul_Tinoco, 18/Mar/2014, 00:40


Ya funciona sin que yo halla tenido que hacer nada. Gracias.

Esque es justamente un articulo muy extenso como para borrarlo, o cortar y pegar.

Es un reportaje importante para mí y que ahora están viendo gente del mundo del cine español y compartiendo.

Fue este mismo sábado por la noche y me metí caña para tenerlo a primera hora del Lunes, o última hora del Domingo, según se mire.

Gracias.


Autor: Raul_Tinoco, 18/Abr/2014, 15:25


Ha vuelto a pasar: https://raultinoco.blogcindario.com/[....]u-y-jara-2014-trabajos-propios.html (Con este articulo).

No creo otro tema por el hecho de que es exactamente el mismo error. Otra cosa es si la solución es la misma.

Muchas gracias y disculpad las molestias.


Autor: Tito, 21/Abr/2014, 09:11


@Raul_Tinoco, es el mismo problema, el cache de Facebook que por alguna razón se ha quedado con ese error.

Desde aquí podrás probar cualquier URL (identificado en facebook):

https://developers.facebook.com/tools/debug/

Si no quieres esperar a que se solucione solo tendrás que editar el título del artículo para que la URL cambie.

EDITO: Parece que al probar el artículo en la herramienta de facebook se actualiza, con lo que ya funciona. Si te vuelve a ocurrir y no quieres esperar, puedes introducir la URL del artículo en la página de debug de facebook.


Autor: Raul_Tinoco, 22/Abr/2014, 11:21


Muchas gracias, lo tendré en cuenta para futuras referencias.