Entrar Regístrate
 
Configurar PHP en windows XP
#1 ·

Muy buenas,

soy nuevo en esto de las páginas web, y necesito trabajar con PHP.

He intentado todo lo que encontraba por interner, desde descargarme primero el php, luego apache etc etc modíficado los archivos que me indicaban pero no había manera, tras consultar con varios amigos me indicaron que el Wamp era una solución muy buena ya que aunaba todo lo que necesitaba, asique borré todo e instalé el Wamp. Me va todo lo de las BBDD y eso perfectamente pero no consigo que mi ordenador entienda el PHP, ni siquiera la simple sentencia de prueba que indican en todos los lados:

<?php
phpinfo();
?>

Mi navegador siempre me muestra el código fuente... os agradecería que me echárais una mano porque llevo algunas semanas buscando solución y es imposible... muchas gracias!


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#2 ·

- si al ingresar en http://localhost ves el saludo de Apache

- puedes administrar las bases de datos desde el phpMyAdmin (esto también indica que Apache está interpretando Php)

Escrito originalmente por adrisanse

<?php
phpinfo();
?>

¿ como llamas al archivo que contiene a este código?


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
#3 ·

Buenas, lo primero gracias por contestar.

Si veo el saludo de "It works" o algo parecido(no recuerdo exáctamente) y sí puedo administrar desde phpMyAdmin.

El archivo lo llamo "prueba.php". Pero vamos, no sólo me pasa con ese, sino con cualquier archivo que veo por ahí .php lo intento ejecutar y no me lo reconoce, siempre me muestra código fuente, es más, en mi .html inserto algun pedazo de código en php como:

<?PHP

   print (“<P>Hola!!!!</P>”);

?>

y me muestra algo como:

Hola!!!!

”);?>

Por lo que no interpreta el php.... me tiene desesperado!!


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#4 ·

Es el Xampp cierto ... ? disculpa la pregunta pero lo ejecutas / activas antes de correr el php que el error que muestras tiene toda la pinta que el php no está ejecutándose. Y el html ejecuta en cualquier navegador sin necesidad de nada más .



xampp.jpg xampp.jpg
Subida el: 09/Oct/2011 19:49
Tamaño: 53.6 KB
Resolución: 714x456 px
Tipo de imagen: JPEG
Descargas: 4

De interés Público
NO AGREGARME COMO AMIGO, gracias
Asuntos claros en los temas
Consultas en temas no afines serán borradas
Tratemos de expresarnos bien, que así da gusto leer


chavp
Moderador
Moderador
Haz clic para ver el perfil del usuario
Mensajes: 20.751
Desde: 20/Dic/2002
· ·
#5 ·

Aclarados unos puntos, y uno de ellos es que está interpretando Php (como dije antes: si se ejecuta PhpMyAdmin...).

Que no puedas ver correctamente (o ejecutar los scripts) .php es otra la causa.

Intenta este script (a ver si experimentas error):

<?php

print ("<P>Hola!!!!</P>");

?>

(copias, pegas y reemplazas el anterior)


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
#6 ·
Escrito originalmente por chavp

Es el Xampp cierto ... ? disculpa la pregunta pero lo ejecutas / activas antes de correr el php que el error que muestras tiene toda la pinta que el php no está ejecutándose. Y el html ejecuta en cualquier navegador sin necesidad de nada más .

No, es el Wamp, el Xampp lo probé en su momento, este es otro de iguales características. Y sí, lo tengo activo con todo corriendo....

@GestionXls

Lo he vuelto a probar ya que había intentado ya con PHP en mayúsculas y minúsculas y nada...


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#7 ·

La prueba no era por las mayusculas/minusculas, sino por las comillas.

que editor usas para escribir Php?

con que codificación guardas esos archivos?


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
#8 ·
Escrito originalmente por GestionXls

La prueba no era por las mayusculas/minusculas, sino por las comillas.

que editor usas para escribir Php?

con que codificación guardas esos archivos?

Ok ok, nada pero lo copié tal y cual y sigo en las mismas...

Uso el Notepad++, pero ya te digo que he probado archivos .php ya hechos y nada...

Codificación?? no entiendo a q te refieres, he probado con archivos .php y con el código dentro de otros .html .... pero no sé si te refieres a eso..


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#9 ·

Codificación:

Block de notas: al guardar como..., debajo del nombre y extensión del archivo debes seleccionar ANSI

Notapad++ (favorito haca un tiempo): en el menú 'Formato' debe estar tildada 'ANSI'

Si tienen otra codificación (que es como se guardan en disco y luego se leen) también se interpretarán de otra forma.

Lo guardas cambiando la codificación, reinicias Apache y ejecutas de nuevo el script.


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
#10 ·

Comprobado en ambos lados... estaba codificado como ANSI, por si a caso le he dado a convertir a ANSI en el notepad++ y sin resultados...


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#11 ·

Si puedes administrar la bases de datos a tarvés de PhpMyAdmin sin ver el código Php es señal inequívoca de que está interpretando bien el código (consecuentemente el problema no está en la configuración de Apache ni de Php).

Son los scripts editados (o no) los que están provocando el error (es el punto donde aplicar la atención).
Cosas de algún diablito...

En cuanto al tipo de instalación y funcionamiento de WAMP no te puedo dar ayuda porque los tengo instalados (y funcionan) de otra forma.


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
#12 ·
Escrito originalmente por GestionXls

Si puedes administrar la bases de datos a tarvés de PhpMyAdmin sin ver el código Php es señal inequívoca de que está interpretando bien el código (consecuentemente el problema no está en la configuración de Apache ni de Php).

Son los scripts editados (o no) los que están provocando el error (es el punto donde aplicar la atención).
Cosas de algún diablito...

En cuanto al tipo de instalación y funcionamiento de WAMP no te puedo dar ayuda porque los tengo instalados (y funcionan) de otra forma.

El PhpMyAdmin me funciona correctamente si, pero el problema no puede estar en los scripts editados, ya que de diferentes sitios me he bajado scripts ya hechos que funcionaban y a mi me sigue pasando lo mismo... no es que sólo me pase con los que yo genero de prueba...

Lo curioso del caso es q me pasa tanto en el PC de casa como en el del trabajo, tanto instalando php y apache sólos como con el programa este... estoy realmente desesperado ya que lo necesito para poder avanzar.... :(


adrisanse
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 6
Desde: 08/Oct/2011
·
#13 ·

Puede ser la configuración de Apache, o mejor la de Php la que este provocando ese error.

Ni con Wamp (ni con Xamp) puedo orientar.... buscaste ayuda en la web de WAMP?


GestionXls
@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 4.001
Desde: 02/Ago/2008
· ·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Ayuda para webmasters · Editores de páginas WEB
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 18:11 UTC+02:00 DST
Temas similares
No se han encontrado temas similares