Entrar Regístrate
 
Problemas con botones de flash (marcos)
#1 ·

Hola a todos espero alguien me pueda hechar la mano con lo siguien y espero explicarme lo mas que se pueda, tengo una pequeña pagina personal con marcos(frames) que son el mainframe y el leftframe, le puse un boton que cree con flash en el leftframe con un link a una pagina y si funciona solo que se abre en otra pagina nueva, lo que quiero es lo siguiente si alguien sabe como abrir la pagina pero en el mainframe hagamelo saber porfavor!!

Gracias de antemano


Sammael2005
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 5
Desde: 17/Mar/2005
·
#2 ·

Tienes que poner el siguiente código:

Codigo:
on (press) {
getURL("Pagina.htm", "mainframe");
}



Hectorc
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 73
Desde: 16/Dic/2004
·
#3 ·

Hola, he insertado un menú en flash en un htm. El menú está en la parte izquierda del htm y quiero que las secciones se abran en la parte de la derecha (en el frame "principal&quot . Cuando intento abrir las secciones se me abren en una nueva ventana y no en el frame "principal". El código que puse en flash, en los botones de cada sección, es el siguiente:

on (release) {
 getURL("seccion1.htm", "principal&quot ;
}

De esta forma no me funciona, ya que se me abre en una nueva ventana ¿Alguien me dice lo que tengo que hacer?


dEi-23D
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 14
Desde: 25/May/2004
· ·
#4 ·

Hola, he insertado un menú en flash en un htm. El menú está en la parte izquierda del htm y quiero que las secciones se abran en la parte de la derecha (en el frame "principal"). Cuando intento abrir las secciones se me abren en una nueva ventana y no en el frame "principal". El código que puse en flash, en los botones de cada sección, es el siguiente:

on (release) {
 getURL("seccion1.htm", "principal") ;
}

De esta forma no me funciona, ya que se me abre en una nueva ventana ¿Alguien me dice lo que tengo que hacer?


dEi-23D
Usuario habitual
Usuario habitual
Haz clic para ver el perfil del usuario
Mensajes: 14
Desde: 25/May/2004
· ·
#5 ·

Para los que tiene problema con Insertar un menu flash en joomla (menu con botones direccionables) y la direccion del boton cargue en la misma pagina donde se aloja este y no abra una nueva ventana.

Despues de 2 semanas de investigar y googlear y de no encontrar solucion al fin me llego la iluminacion y esta es la que me funciono.

el codigo que se mete en el boton es este:

Código:
on (press)
{
    getURL("http://www.google.com.co", "_self", "GET");
}

Y para insertarlo en el header del template de joomla  es esto:

Código:
<center><object height="452" width="905" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0">
<param name="movie" value="ACA EL NOMBRE DEL .SWF" />
<param name="quality" value="high" />   <embed height="252" width="905" src="http://ACA LA RUTA DEL ARCHIVO .SWF" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash"></embed> </object></center>

Y va a funcionar.

para que tengan mas informacion sobre esta guia: aca les dejo el .fla para que lo vean.

Código:
http://depositfiles.com/files/qdse171yw

descargasfree
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 2
Desde: 14/Ene/2010
·
#6 ·

No revivas viejos temas.

Un saaludo.


iblancasa
Come y duerme en el foro
Come y duerme en el foro
Haz clic para ver el perfil del usuario
Mensajes: 362
Desde: 17/Nov/2009
·
#7 ·

Hola,

Lo revivo porque en muchas paginas no he encontrado respuesta y muchas personas tienen el mismo problema para insertar menus con botones en flash.

El problema es que, al insertarlo al clicar en el boton el abre la direccion que se le fue dada en una ventana nueva y la carga en la misma pagina.


descargasfree
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 2
Desde: 14/Ene/2010
·
#8 ·
Escrito originalmente por descargasfree

Hola,

Lo revivo porque en muchas paginas no he encontrado respuesta y muchas personas tienen el mismo problema para insertar menus con botones en flash.

El problema es que, al insertarlo al clicar en el boton el abre la direccion que se le fue dada en una ventana nueva y la carga en la misma pagina.

Abre un nuevo tema, no revivas antiguos.

Además estaría bien que en ese nuevo post pongas el código de los frames y expliques mejor.

Un saludo.


iblancasa
Come y duerme en el foro
Come y duerme en el foro
Haz clic para ver el perfil del usuario
Mensajes: 362
Desde: 17/Nov/2009
·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Ayuda para webmasters · Macromedia Flash
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 09:53 UTC+02:00 DST
Temas similares
No se han encontrado temas similares