Problemas con planilla decontacto CCS / PHP
#1 ·
Hola: estoy teniendo un problema para hacer funcionar correctamente el formulario de contacto de mi pagina web. En realidad funciona el envío y recibo los email pero vacíos, sin contenido alguno
 
Les dejo los códigos a ver si me pueden ayudar
 
HTML
 
<td width="663" bgcolor="#D4D0C8"><span class="TextoOscuro" id="spryNombre">
       <input type="text" name="Nombre" id="Nombre" />
       <span class="textfieldRequiredMsg">Se necesita un valor.</span></span></td>
     </tr>
     <tr>
       <td bgcolor="#D4D0C8"><div align="right"><span class="TextoOscuro">Teléfono:</span></div></td>
       <td bgcolor="#D4D0C8"><span class="TextoOscuro" id="spryTelefono">
       <input type="text" name="Teléfono" id="Teléfono" />
       <span class="textfieldRequiredMsg">Se necesita un valor.</span></span></td>
     </tr>
     <tr>
       <td bgcolor="#D4D0C8"><div align="right"><span class="TextoOscuro">E-mail:</span></div></td>
       <td bgcolor="#D4D0C8"><span class="TextoOscuro" id="sprytEmail">
       <input type="text" name="E-mail" id="E-mail" />
       <span class="textfieldRequiredMsg">Se necesita un valor.</span></span></td>
     </tr>
     <tr>
       <td bgcolor="#D4D0C8"><div align="right"><span class="TextoOscuro">Ciudad:</span></div></td>
       <td bgcolor="#D4D0C8"><span class="TextoOscuro" id="spryCiudad">
         <input type="text" name="Ciudad" id="Ciudad" />
       </span></td>
     </tr>
     <tr>
       <td bgcolor="#D4D0C8"><div align="right"><span class="TextoOscuro">Mensaje:</span></div></td>
       <td bgcolor="#D4D0C8"><span class="TextoOscuro" id="spryMensaje">
       <textarea name="Mensaje" id="Mensaje" cols="45" rows="5"></textarea>
       <span id="countsprytextarea1">&nbsp;</span><span class="textareaMaxCharsMsg">Se ha superado el número máximo de caracteres.</span></span></td>
     </tr>
     <tr>
       <td colspan="2" bgcolor="#D4D0C8"><div align="center">
         <span class="TextoOscuro">
         <input name="Enviar" type="submit" class="Listado" id="Enviar" value="Enviar" />
         </span></div></td>
       </tr>
     <tr>
       <td colspan="2" bgcolor="#D4D0C8" class="TextoOscuro"><div align="center">Cel: 011-15-55074408 / 011-15-61200021</div></td>
     </tr>
   </table>
   <p>&nbsp;</p>
 </form>
--------------------------------------------------------------------------- -------------------------------------------------------------------
<?php
$mail = "contacto@learqs.com.ar";
$nombre = $_POST[´nombre´];
$teléfono = $_POST[´teléfono´];
$email = $_POST[´email´];
$ciudad = $_POST[´ciudad´];
$mensaje = $_POST [´mensaje´];
$Thanks ="Gracias.html";
 
 
$mensaje = "
$nombre= ".$nombre."
$teléfono= ".$teléfono."
$email= ".$E-mail."
$ciudad= ".$ciudad."
$mensaje= ".$mensaje."
";
 
if (mail ($mail,"Nuevo mensaje de Página Web",$message))
 
Header ("location: $Thanks");
echo "Mensaje enviado correctamente";
?>
 
Muchas Gracias
 

Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 1
Desde: 21/Ene/2014
·
#2 ·

Ese código php esta mal escrito, faltan muchos puntos y comas, por ejemplo.

En general, para este tipo de problemas, lo que tienes que hacer en el php que envia el mail es imprimir por pantalla los datos que has recogido, para ver si realmente lo estas recogiendo bien.


@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 30.299
Desde: 01/Mar/2003
· ·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Espacio WEB · PHP
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 20:57 UTC+02:00 DST
Temas similares
 I FotoPTemaMensajesÚltima respuesta
No Hay mensajes nuevosHaz clic para ver el perfil del usuario108/Jun/2009, 08:11
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario101/Nov/2011, 07:11
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Problemas al usar xhtml con php
Por: · 07/Dic/2006, 13:44
107/Dic/2006, 16:20
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario125/Ene/2006, 20:51
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario116/Ago/2003, 09:35
 Ir al último mensaje del tema
Recomendado