home Foro de soporte Espacio WEB MySQL
 
Conexión de base de datos a sitio web
#1 ·

Hola querida gente de mi@, ando necesitando ayuda en mi web cual quise hacer un formulario y bueno, cuando veo los formularios en localhost no sale nada malo (ningun error) ahora en la web, saltan todos y pude sacar varios que no tenian sentido pero queda uno: Datos de conexion incorrectos. Nosé nosé porque sale, debo colocar la base de datos en el servidor tambien (.sql) porque ya lo he echo. Aquí les dejo lo que intentaba hacer:

index.php

<form name="login_user" action="login.php" method="post" />

<div align="right">
<table width="221" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="99"><span class="Fuentepass">Usuario:</span></td>
<td width="122"><label>
<input name="usuario" type="text" id="usuario" size="20" maxlength="20">
</label></td>
</tr>
<tr>
<td><span class="Fuentepass">Contrase&ntilde;a:</span></td>
<td><label>
<input name="contraseña" type="password" id="contraseña" size="20" maxlength="20">
</label></td>
</tr>
</table>
</div>
<div align="right"><span class="Fuenteregistrarse">Olvidaste tu contrase&ntilde;a? | <a href="registro.php">Registrate!</a></span>

<input type="submit" name="enviar" id="enviar" value="Iniciar">
</div>
</form>

 esto estaría obviamente en el body, ubicado en la cabecera y yo afuera del <html> puse el siguiente codigo para conexion:
conexion.php

<?php
$nombre_server[1] = 'localhost';
$nombre_user[2] = 'juliangorge';
$password[3] = ' **************** ';
$nombre_db[4] = 'registro';

$conectar = @mysql_connect($nombre_server[1],$nombre_user[2],$password[3]) or exit('Datos de conexion incorrectos.');
mysql_select_db($nombre_db[4]) or exit('No existe la base de datos.');

session_start();

function limpiar($var)
{

$var = trim($var);
$var = htmlspecialchars($var);
$var = str_replace(chr(160),'',$var);
return $var;
}

function validar_email($email){
$mail_correcto = 0;
if ((strlen($email) >= 6) && (substr_count($email,"@") == 1) && (substr($email,0,1) != "@") && (substr($email,strlen($email)-1,1) != "@"))
{
if ((!strstr($email,"'")) && (!strstr($email,"\"")) && (!strstr($email,"\\")) && (!strstr($email,"\$")) && (!strstr($email," ")))
{
if (substr_count($email,".")>= 1)
{
$term_dom = substr(strrchr ($email, '.'),1);
if (strlen($term_dom)>1 && strlen($term_dom)<5 && (!strstr($term_dom,"@")) )
{
$antes_dom = substr($email,0,strlen($email) - strlen($term_dom) - 1);
$caracter_ult = substr($antes_dom,strlen($antes_dom)-1,1);
if ($caracter_ult != "@" && $caracter_ult != ".")
{
$mail_correcto = 1;
}
}
}
}
}
if ($mail_correcto)
return 1;
else
return 0;
}

function user_login()
{
if(!$_SESSION['id'])
{
exit ("Solo usuarios registrados, <a href='javascript:history.back(-1)'>Volver</a>");
}
}
?>

Lo que intenté fue hacerlo con un usuario distinto al de root, cual solo configuré los privilegios (si hay que agregar algo) aparte de los demás archivos de configuración .php para el formulario por ahora mi grave problema es ese la conexión, que es lo que me está frustando en la mayoría de los códigos que estoy probando. Muchas gracias y espero una respuesta pronta. Esta es la web: cuboxcuboserver.com.ar


Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 1
Desde: 29/Jul/2012
·
#2 ·

Tendrás que poner el error exacto que te da y en que página y línea...


@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 30.309
Desde: 01/Mar/2003
· ·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Espacio WEB · MySQL
Opciones:
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 17:03 UTC+02:00 DST
Temas similares
 I FotoTemaMensajesÚltima respuesta
No Hay mensajes nuevosHaz clic para ver el perfil del usuario118/Nov/2012, 18:36
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario316/Dic/2010, 19:33
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Base de datos en mi web
Por: · 07/May/2010, 09:29
107/May/2010, 16:50
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Conexion con base de datos
Por: · 03/Ago/2009, 14:10
103/Ago/2009, 14:18
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario131/Ene/2009, 23:26
 Ir al último mensaje del tema