home Foro de soporte Servicio Blogs Blogs General
 
¿Porque el truco de poner hora no me va?
Haz clic para ver el perfil del usuario
Machacateclados
Machacateclados
·
#1 ·

Vamos a ver. He pegado en mi blog, el codigo de effectedcard para que aparezca la hora y el dia y demas. Lo he colocado en la plantilla, tanto en el menu izdo como en el derecho. Incluso en la cabecera o en alguna zona de ella (no controlo mucho lo de pegar etiquetas, es decir, copiar y pegar si, pero no estoy seguro de saber si es o no adecuado hacerlo en un lugar u otro).

Otras etiquetas e ido poniendolas y cambiandolas de lugar en la plantilla pero la de la hora es imposible que me salga.

¿Que hago mal?Llorica

Haz clic para ver el perfil del usuario
Machacateclados
Machacateclados
·
#2 ·

[cita title=
¿Que hago mal?Llorica[/cita]

¿Tengo que añadir algo al codigo html? ¿Es un problema de configuracion? Esque ya lo he quitado, puesto, repuesto, actualizado, reactualizado, y en fin de casi todo, y nada.

¿Que carajos he de tener en cuenta para que me salga bien? Alguna psta?

Haz clic para ver el perfil del usuario
@man / @woman
@man / @woman
· ·
#3 ·

Dinos como lo has puesto... pon aquí tu cacho de código.


Recuerda no ponerlo dentro de un bloque de los de mi@.

Haz clic para ver el perfil del usuario
Machacateclados
Machacateclados
·
#4 · ·
Escrito originalmente por NoSetup.org
Dinos como lo has puesto... pon aquí tu cacho de código.


Recuerda no ponerlo dentro de un bloque de los de mi@.


Vale el cacho codigo (o parte de el es este)
Codigo PHP:

<!-- MENU DEL BLOG -->
    <MenuBlog>
    <!-- En este caso, la condicion para formar un menu en dos columnas es que ContenidoBlog este dentro de MenuBlog -->

        <!--menu de la izquierda-->
        <div id="menui">
            <!-- El Tiempo en Valencia, España en tu web - Código HTML - miarroba.com -->
<SPAN id="mia_weather_link_539f"><A href="http://miarroba.com">miarroba.com</A></SPAN>
<SCRIPT type="text/javascript" src="http://tiempo.miarroba.com/webmaster/weatherbox.php?locid=SPXX0082&box=18&units=1&segid=34fd4"></SCRIPT>
<!-- Fin del código -->
<DIV align=center><b><font face="Arial" size="2" color="#0000FF">
<SPAN
id=clock>
<SCRIPT language=JavaScript>
<!-- Begin
var dayarray=new Array("Domingo","Lunes","Martes","Miércoles","Jueves","Viernes","Sábado"
var montharray=new Array("Enero","Febrero","Marzo","Abril","Mayo","Junio","Julio","Agosto","Septiembre","Octubre","Noviembre","Diciembre"
function getthedate(){
var mydate=new Date()
var year=mydate.getYear()
if (year < 1000)
year+=1900
var day=mydate.getDay()
var month=mydate.getMonth()
var daym=mydate.getDate()
if (daym<10)
daym=""+daym
var hours=mydate.getHours()
var minutes=mydate.getMinutes()
var seconds=mydate.getSeconds()
var dn="AM"
if (hours>=12)
dn="PM"
if (hours>12){
hours=hours-12
}
{
d = new Date();
Time24H = new Date();
Time24H.setTime(d.getTime() + (d.getTimezoneOffset()*60000) + 3600000);
}
if (hours==0)
hours=12
if (minutes<=9)
minutes="0"+minutes
if (seconds<=9)
seconds="0"+seconds
//change font size here
var cdate=dayarray[day]+" "+daym+" de "+montharray[month]+" de "+year+" &nbsp;&nbsp;&nbsp; "+hours+":"+minutes+":"+seconds+" "+dn+""
if (document.all)
document.all.clock.innerHTML=cdate
else if (document.getElementById)
document.getElementById("clock".innerHTML=cdate
else
document.write(cdate)
}
if (!document.all&&!document.getElementById)
getthedate()
function goforit(){
if (document.all||document.getElementById)
setInterval("getthedate()",1000)
}
window.onload=goforit
// End -->
</SCRIPT>
</SPAN></font></b></DIV>

            <!-- BUSCADOR -->
            <BloqueBuscador>
            <div class="titulomenu">
            <h4>Buscador</h4>
            </div>
            <form action="<@UrlBuscadorBlog@>" class="buscador" method="post">
                <ul class="buscador">
                    <li class="texto"><input type="text" name="texto" maxlength="50" /></li>
                    <li class="submit"><input type="submit" name="buscar" value="Buscar" /></li>
                </ul>
            </form>
            </BloqueBuscador>
            <!-- FIN BUSCADOR -->



He puesto el codigo de la hora de color rojo, el resto es lo que hay antes y lo que hay despues.
Entiendo que ponerlo en los bloques de mi@ es dentro de las votaciones, tagboard, articulos anteriores, buscador, etc. Pero no es el caso....vamos creo yo. Y de todos modos para que saliera debajo de la cabecera y no en los bloques derecho o izquierdo, onde tendria que ponerlo

Ah, y no pongo el enlace de mi blog, porque me ha parecido entender en algun post que eso seria considerado como spam.RollEyes ¿Eso es asi?

Gracias Nosetup.org
Haz clic para ver el perfil del usuario
@man / @woman
@man / @woman
· ·
#5 ·

En principio parece bien puesto... y hasta aquí llega mis conocimientos.

Haz clic para ver el perfil del usuario
Colega ;)
Colega ;)
· ·
#6 ·

Yo veo varias cosas mal, bueno creo. No controlo tampoco mucho del tema.

No esta permitido poner el enlace del blog (salvo en algunos casos), para evitar que la gente pregunte chorradas y ponga su blog para ganar visitas. Esto seria un caos.


Te he buscado otro reloj para dejarnos de lios Vacilando Igualmente, estoy seguro que el otro bien puesto si funciona.


http://www.desarrolloweb.com/articulos/549.php?manual=22

Haz clic para ver el perfil del usuario
Moderador
Moderador
· ·
#7 ·

¿El codigo ahora lo tienes puesto? o lo quitaste al ver que no funcionaba?. Te lo pregunto porque en determinados momentos el proceso de que los cambios se reflejen en la plantilla me han llevado varios minutos. No vaya a ser que te esté pasando eso.
Tambien sería bueno que luego de republicar el blog y antes de entrar de nuevo, borres los temporales del navegador... o sea renueves la cache del mismo.




El que vence a los demás es poderoso, el que se vence a sí mismo es invencible


Haz clic para ver el perfil del usuario
Machacateclados
Machacateclados
·
#8 ·
Escrito originalmente por Torry_II
¿El codigo ahora lo tienes puesto? o lo quitaste al ver que no funcionaba?. Te lo pregunto porque en determinados momentos el proceso de que los cambios se reflejen en la plantilla me han llevado varios minutos. No vaya a ser que te esté pasando eso.
Tambien sería bueno que luego de republicar el blog y antes de entrar de nuevo, borres los temporales del navegador... o sea renueves la cache del mismo.


Hola Torry_II. Bueno pues creia que lo habia quitado, pero no estaba ahi, y ha estado todo el dia, por lo que tiempo ha habido. He borrado los archivos temporales y nada, de nada. Asi que he decidido probar otra cosa.
He cambiado de plantilla, he copiado el codigo de otra de las de mi@ y le he insertado el parche dichoso, y bueno, actualizado el blog, borrado de ficheros temporales, y un rezo.loco
Resultado de momento nada.

El tiempo y yo estamos reñidos. No en vano nunca llevo reloj.

Asi que he decidio dejarlo de momento, y mañana lo intentare de nuevo o utilizar las herramientas indicadas por EffecteCard.


Gracias por todoSonrisa
Haz clic para ver el perfil del usuario
Moderador
Moderador
· ·
#9 ·

El código colocado por Effectedcard tiene un "careto" en una parte, y eso seguro que genera el error ya que al copiar y pegar el código se está omitiendo un paréntesis estimo.

EffectedCard, revisa el código (el careto es el guiño)
O sea este Giño

Centreitaca... espera la respuesta de EffectedCard.




El que vence a los demás es poderoso, el que se vence a sí mismo es invencible


Haz clic para ver el perfil del usuario
Machacateclados
Machacateclados
·
#10 ·
Escrito originalmente por Torry_II
El código colocado por Effectedcard tiene un "careto" en una parte, y eso seguro que genera el error ya que al copiar y pegar el código se está omitiendo un paréntesis estimo.

EffectedCard, revisa el código (el careto es el guiño)
O sea este Giño

Centreitaca... espera la respuesta de EffectedCard.



Por fin ya me va. Biennnnnn.

Lo que he hecho es lo siguiente, he copiado el codigo que habia no en el subforo de trucos blog, sino en el de trucos foros de mi@, y aparentemente el codigo es el mismo, pero como dice Torry_II me inclino a pensar que el careto Giño tiene algo que ver, ...

Gracias, por vustras indicaciones, y EffectedCard gracias por el otro codigo, pero tenia que conseguirlo con este, cuestion de berzotas que es uno. Ahora probare el otro codigo pero para el foro que tengo.

SonrisaSonrisaSonrisaSonrisaRebotado
Haz clic para ver el perfil del usuario
Colega ;)
Colega ;)
· ·
#11 ·

A mi no me preocupa que codigo uses. Es mas, te proporcione otro codigo porque ya intuia que ese era el problema y no tenia tiempo para revisar donde fallaban los caretos (creo recordar que tiene mas de uno). Por otra parte sabiendo que el de los foros funciona, lo corrijo enseguida.

ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Servicio Blogs · Blogs General
Opciones:
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 02:43 UTC+01:00
Temas similares
No se han encontrado temas similares