Entrar Regístrate
 
Ayuda!! conexion con base de datos
#1 · · Editado por zalatron

Hola,

A ver si alguien me puede ayudar..

Os cuento mi problema,

Actualmente estoy cambiando de hosting, y estoy haciendo ahora todos los ajustes para el nuevo hosting antes de publicar la web desde este hosting. (La web actualmente la tengo alojada en el antiguo servidor funcionando con la base de datos perfectamente y sin problemas).
El caso, es que una vez subidos todos todos los archivos al nuevo servidor y creada la nueba base de datos a la que he importado todos los datos de la (antigua) que actualmente está funcionando bien como digo.
La he creado con un nuevo nombre, usuario y contraseña y estos datos los he puesto en el archivo de conexión.php para este nuevo hosting.

Archivo de conexión.php

<?php

function conexionmysql(){
$servidor = "localhost";
$usuario = "el de la base";
$pass = "la nueva de la base";
$db = "el nuevo usuario";
$enlace = mysql_connect($servidor, $usuario, $pass);
mysql_select_db($db, $enlace);

mysql_query("SET NAME 'utf8'");
mysql_query("SET CHARACTER SET 'utf8' COLLATE 'utf8_unicode_ci'");

return $enlace;
}

?>

 Y parece que conecta bien, pero no acaba de completar la consulta y arroja un error en este nuevo hosting que no se que hacer...  ( en el otro repito, todo funciona correctamente).  www.mallarme.com.mx/galerias.php
Aqui hace la consulta y carga las imagenes bien, y en el nuevo no hace la carga en vez de las imagene me lanza este error:
      Warning: 1 to be resource, boolean given in/home/malla805/public_html/galerias.php on line 355
Que son estas lineas de código en cuestión:

ARCHIVO GALERIAS.PHP

<?php
if($fp = fopen("gal_a_T1.php", "r")){
$data = fread($fp, filesize("gal_a_T1.php"));
fclose($fp);
} else {
$data = "";
exit ("<h1>Error</h1>n<p>No se puede escribir el archivo, asegurate que los permisos son correctos(CHMOD 777).</p>");
}
?>
<?php
echo "<tr><td>";
echo "$data";
echo "</td></tr>";
?>


En otro foro he leido que podía ser algo de los privilegios de acceso a la base desde el archivo conexion.php,
Pero estos parecen estar bien....

Alguna idea??
Gracias y saludos!


zalatron
Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 1
Desde: 13/Abr/2014
·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Espacio WEB · PHP-Nuke, phpBB y similares
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 16:36 UTC+02:00 DST
Temas similares
 I FotoPTemaMensajesÚltima respuesta
No Hay mensajes nuevosHaz clic para ver el perfil del usuario114/Abr/2006, 12:20
NoSetup.org Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario329/Oct/2004, 20:16
NoSetup.org Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario126/Dic/2008, 11:52
NoSetup.org Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario106/Feb/2010, 20:50
Invitad@ Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario0Hoy, 01:00
Invitad@ Ir al último mensaje del tema