home Foro de soporte Espacio WEB PHP-Nuke, phpBB y similares
 
Modulo creado por mi inactivo para usuarios Nuke 8.0
#1 ·

Bueno, mi problema es el siguiente.

He creado un módulo propio combinando php y html. Lo he metido dentro de un archivo index.php, y este a su vez dentro de su correspondiente carpeta en /modules.

Activo el módulo, meto un enlace en un bloque, y si como administrador pincho sobre el enlace, veo perfectamente el módulo recién creado, el cual funciona a las mil maravillas.

Ahora bien, si me desconecto como administrador e intento entrar en el enlace como usuario, me dice que el módulo no está activo.

Evidentemente, el módulo lo tengo activado en el menú de módulos de Administración.

¿Sabeis cual puede ser el problema?, porque me da que seguro que es alguna tonteria.

Por si acaso, os dejo el código php del archivo index.php del módulo nuevo por si el problema residiera en el código fuente:

--------------------------------------------------------------------------- --------------

<?PHP
if(!defined('MODULE_FILE') & !eregi("modules.php", $_SERVER['PHP_SELF'])){header("http://lamazmorramalaga.freehostia.com/index.php");die();}
require_once("mainfile.php");
$module_name = basename(dirname(__FILE__));
define('INDEX_FILE', true);
$index=1;
include("header.php");
OpenTable();
?>

AQUÍ VAN LAS 150 LÍNEAS DE CÓDIGO HTML QUE OBVIARÉ COPIAR

<?PHP
CloseTable();
include("footer.php");
?>

--------------------------------------------------------------------------- ---------------------

Esto es todo el código php que tiene el mísero módulo :z)

Gracias de antemano por vuestras respuestas.


Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 7
Desde: 23/Sep/2008
·
#2 ·

Los modulos también depende del nivel de acceso. Mira en el panel de administración de modulos, que nivel le has puesto.


@man / @woman
@man / @woman
Haz clic para ver el perfil del usuario
Mensajes: 30.299
Desde: 01/Mar/2003
· ·
#3 ·

Es curioso y mas raro aun el tema.

En un segundo módulo recien creado, le he dado a activar ahora mismo, y comprobado el nivel de permisos que me comentas.

Al fijar el nivel de permisos como "Todo el mundo", si lo puedo ver, aun entrando como usuario.

Sin embargo, el otro módulo que tenía antes creado no puedo. ¿Puede depender del CHMOD del archivo index?


Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 7
Desde: 23/Sep/2008
·
#4 ·

DIOOOOOOOOOOOS, soy muuuuuy burro.

Al crear el módulo, he creado una carpeta que contendrá varias subcarpetas con diferentes index´s. Sin embargo, en un momento brillante, en la principal, que está incluida como módulo, no tengo ningún archivo index.

Por eso, cuando pincho en el enlace que está correctamente creado, con tooooda la ruta a este segundo index metido en la subcarpeta, me funciona. Sin embargo, como usuario, el módulo no me puede funcionar porque no tiene ningún index en la carpeta principal dentro del módulo

Espero haber sido claro por si algún otro tarugo como yo le pasa y por supuesto, MUCHIIIIISIMAS GRACIAS, NoSetup por tu respuesta. ;-)


Usuario Novato
Usuario Novato
Haz clic para ver el perfil del usuario
Mensajes: 7
Desde: 23/Sep/2008
·
ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Foro de soporte · Espacio WEB · PHP-Nuke, phpBB y similares
Opciones:
Versión imprimible del tema
Subscríbete a este tema
Date de baja de este tema
Ir al subforo:  
TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro
Ahora son las 14:11 UTC+01:00
Temas similares
 I FotoPTemaMensajesÚltima respuesta
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Modulo php nuke
Por: · 12/Jul/2009, 10:15
113/Jul/2009, 20:35
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario0Hoy, 01:00
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
REGISTRO DE USUARIOS.- NUKE 8.1
Por: · 23/Feb/2008, 11:17
224/Feb/2008, 06:35
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario0Hoy, 01:00
 Ir al último mensaje del tema
No Hay mensajes nuevosHaz clic para ver el perfil del usuario
Registro de usuarios NUKE
Por: · 27/Abr/2004, 13:02
427/Abr/2004, 17:00
 Ir al último mensaje del tema
Recomendado