Foro de soporteServicio BlogsBlogs General
Responder 
Problema grave con el pié del blog
Haz clic para ver el perfil del usuario

Foro por via intravenosa
Foro por via intravenosa

#1

Estuve haciendo algunos cambios en el blog, agregandole cosillas, y ahora se me fue el pié a la parte de abajo del menú derecho, y la publicidad que esta debajo del pié queda abajo sola, pero si pongo a mirar los comentarios publicados, debajo de estos, pegadita está la publi.
Como me estoy volviendo loca porque hace tres días que le estoy haciendo de todo y no logro encontrar el problema, es por eso que estoy pidiendo ayuda, ya no se que mas hacer ni que cosa pudo haber desencadenado esto, todo lo que le puse lo fui quitando gradualmente y mirando, lo he vuelto a poner y nada... todo igual... en los dos navegadores
Agradezco cualquier ayuda

Haz clic para ver el perfil del usuario

#2
Escrito originalmente por k_nelita
Estuve haciendo algunos cambios en el blog, agregandole cosillas, y ahora se me fue el pié a la parte de abajo del menú derecho, y la publicidad que esta debajo del pié queda abajo sola, pero si pongo a mirar los comentarios publicados, debajo de estos, pegadita está la publi.
Como me estoy volviendo loca porque hace tres días que le estoy haciendo de todo y no logro encontrar el problema, es por eso que estoy pidiendo ayuda, ya no se que mas hacer ni que cosa pudo haber desencadenado esto, todo lo que le puse lo fui quitando gradualmente y mirando, lo he vuelto a poner y nada... todo igual... en los dos navegadores
Agradezco cualquier ayuda
Hola K-nelita:

Bueno, no atisbo bien que puede ser, pero has subido la publi a la cabecera verdad?

Yo entre en tu blog ayer o antesdeayer y no vi nada raro con el pie, y ahora tampoco aprecio el problema. Supongo que estaras trasteando con el codigo de la plantilla.

Si veo que el cuadro de sindicacion no aparece. Debes haberlo borrado. Lo que aparece es esto <@SindicacionTitulo@> que es parte del bloque de sindicacion, pero parece que se haya quedado fuera de etiquetas
Codigo


Este codigo de sindicacion no esta cerrado, y lo veo algo descuajeringado

Ves probando y por partes y dime como tendria que quedar y le voy hechando un vistacillo.

Un abrazo



Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#3

Hola.
Bueno yo tampoco vi nada de lo que comentas, habras modificado ya supongo, y lo que te comenta paseantedelforo, bueno ahi solo cierra la etiqueta </a por </a> ya que ahi la tienes sin cerrar, por eso no se te muestran las sindicaciones.

Al ver el codigo de pasada mire varios errores, pero no vi errores en capas (solo mire de pasada asi que en ese momento no vi en capas), ¿y creo tampoco vi el pie de la pagina? lo quitaste o me equivoco.

Saludos.

Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#4

Por cierto en lo que comentaba de la sindicacion veo que no cerraste tampoco la primera etiqueta, lo cual debes colocar asi:

Codigo

 Por cierto ahora que vi el codigo para ver si habias quitado el pie, veo que asi fue, ya que no lo vi. Debo suponer lo hiciste para que se te mostrara ese error que decias.
Haz clic para ver el perfil del usuario

#5
Escrito originalmente por pacosombreday
Por cierto en lo que comentaba de la sindicacion veo que no cerraste tampoco la primera etiqueta, lo cual debes colocar asi:
Codigo

 Por cierto ahora que vi el codigo para ver si habias quitado el pie, veo que asi fue, ya que no lo vi. Debo suponer lo hiciste para que se te mostrara ese error que decias.
Si, por el motivo que sea hay capas que no estan cerradas y acabo de advertir el mismo problema con varios de los ultimos bloques que tienes en tu menu derecho, (enlaces, promocionate, etc).


Si estas trasteando con la plantilla, ten a mano una copia de seguridad, por si acaso en una de esas se corre demasiado el Delete ( )

y dinos algo cuando acabes de trastear, porque sino, habran tantos cambios que no sabremos por donde mirar

Un saludo a los dos (va por ti pacosombreday.... que por cierto algun dia tendras que explicar ese nick ... es puñetera curiosidad de como nacen las cosas).



Haz clic para ver el perfil del usuario

Foro por via intravenosa
Foro por via intravenosa

#6

Bueno muchas gracias a los dos por mirar mi estropeado blog.
Vamos por partes, dijo Jack, lo del bloque sindicación, solo y sin ningun motivo se borró la parte de abajo, no solo la sindicacion sino todo lo que va mas abajo, incluso la publi que estaba allí, lo volví a copiar (porque si tengo copia de seguridad), republicaba y nada quedaba todo igual con la ultima parte de las sindicaciones y el resto sin salir en la plantilla, como tres veces lo hice o mas. Al fin quedó, pero el pié sigue al terminar el menú derecho, y la publi abajo de todo, si pueden mirenlo ahora, antes que vuelva a meterle mano.
El pié que no vieron es quizas porque está debajo de sindicacion, es una barra dorada y parece terminar al final del menú, pero el menú no termina con ninguna barra dorada, ese es el pié del blog.
Le saqué un script que tenía para poner texto en el nombre del blog, en el navegador, y eso parece haber arreglado algo, al menos me aceptó lo que no podía poner de la sindicación, no se que tiene que ver, pero me gustaría ponerlo de nuevo, pero si me descuajeringa todo no se que hacer.
Gracias por mirarlo y si pueden hacerlo nuevamente, mas gracias

Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#7

Hola K_nelita.

Bueno hay van unas soluciones:

Saca el pie del contenedor, despues de que termine la capa del contenedor, agrega el pie que tienes ahi..

este es tu pie que vi:

Codigo

 Ese lo tienes dentro del contenedor, solo muevelo despues de que termina el contenedor, y dentro del pie padding puedes agregar la publi.

Para que te quede algo asi:

<div id="pagina">
  <div id="contenedor">
     las capas de los lados aqui
  </div> cierre del contenedor
  <div id="pie"> </div>
</div> cierre de la pagina aqui

estas solo te las coloco para que veas solo las capas por asi decirlo superiores.

A por cierto cierra tambien la etiqueta de apertura de html no la cierras,  me refiero a <html> la cual la tienes sin el >, osea asi <html , esa es una de las que tienes mal, ya que segun veo hay mas etiquemas mal.

Bueno una recomendacion mas, revisa bien toda la estructura ya que sigue habiendo errores en tu estructura.

Saludos.



Saludos.
Haz clic para ver el perfil del usuario

Foro por via intravenosa
Foro por via intravenosa

#8

Hola pacosombreaday, gracias por tu paciencia y explicaciones, pero para serte sincera no entiendo casi nada, me hablas del contenedor y no se a que te refieres, y el html mal cerrado, y yo lo veo cerrado.
Mira aquí te copio esa parte de la plantilla, que es lo que yo veo, si podés decime que es lo que crees que debo corregir:

<!-- FIN DE LA TAG QUE DEFINE EL MENU -->
</MenuBlog>

<!-- DIV QUE LIMPIA LOS FLOAT DE MENUS Y CUERPO -->
<div class="limpiador"> </div>

</div><div id="pie"><div id="pie_padding"></div></div><!-- FIN DE LOS DIVS DE LA PAGINA -->
</div>
<center><@Publicidad_468x60@></center>
</div>
</body>
</html>

Antes también estaba así y no había ningún problema, el pié salía donde debería y la publi debajo, vos ves que falte algo allí?  Algún </div> quizás?
Bueno muchas gracias por tu ayuda
Un saludo

Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#9

Sobre el contenedor ahi te lo puse en el tema anterior, me refiero a este <div id="contenedor"> , donde despues de que se cierra el contenedor ya agregar el pie, pero para explicarme mejor, de acuerdo al codigo que colocaste en el mensaje yo te lo acomodaria asi:

Codigo
Lo que hago ahi solo es mover el pie fuera del contenedor pero estando dentro de la capa pagina.

A y sobre lo de la etiqueta html, en el codigo no aparece cerrada, me refiero a esta mira:
Codigo
En tu codigo la has de tener asi:
Codigo
Como ves este que te puse no esta cerrada al final, asi que corrigiendolo debe quedar asi para que este correcto:
Codigo
Aun asi, tienes varios errores  en el codigo, pero no creo esos ocacion el error que dices, pero prueba eso, si sigue pues como te comente en otro mensaje, revisa mas detenidamente tu estructura la cual sigue teniendo detalles malos.

Saludos.
Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#10

Por cierto se me olvido comentar algo del codigo que te puse, ya que solo contemple esta parte del codigo que me pusiste:

Codigo
Esa parte remplazala con la parte que te puse, osea, en vez de esa parte remplazala con esta que te coloque en el mensaje anterior y la cual te vuelvo a colocar ahora:
Codigo
Por cierto alguien sabe el limite para poder editar los mensajes, o no se puede en este foro? ya que habia leido que aqui habia un limite para editarlos, para no escribir mensajes seguidos.
Haz clic para ver el perfil del usuario

Foro por via intravenosa
Foro por via intravenosa

#11

Muchas gracias pacosombreday, si era esa etiqueta mal cerrada, la del html>  seguramente se me fue la mano con el deleete como dijo paseantedelforo.
No hizo falta corregir lo de la ubicacion del pié, ya así queda donde estaba.
Pero me dejas preocupada porque dices que tengo mas errores, ya he revisado todo, estoy bizca de mirar etiquetas y no encuentro nada.
Pero lo he mirado con IE ahora y la cabecera sale desplazada hacia abajo, como que se mete bajo el menú, no se que será eso, en FF sale bien.
En IE también hay algunas fotos que no salen, mejor dicho imagenes, con códigos, o sea banners, mi Dios... en el menú derecho.
No hay algún programa que te revise el html o códigos para saber que es lo que está mal? No puedo seguir abusando de tu amabilidad, sino te mandaría mi plantilla....
Mil gracias!!!

Haz clic para ver el perfil del usuario

Usuario habitual
Usuario habitual

#12

Lo que comentas de la cabecera es por las medidas,  para ello puedes hacer:

Ir a la hoja de estilo, osea el css y modifica en:
       #cabecera  
modificale el height ponlo para que este asi;
     height:179px;

y a la imagen que tienes en la cabecera agregale esto:
width="756px" (esta solo para que se acomode un poco el ancho segun las medidas que tienes)


Si hay un hueco que veas entonces juega un poco mas con esas medidas.

Lo de las imagenes que dices debe ser por algun error en la etiqueta, pero si no dime cual y la checo.

Saludos.

Haz clic para ver el perfil del usuario

#13
Escrito originalmente por k_nelita

No hay algún programa que te revise el html o códigos para saber que es lo que está mal?
http://jigsaw.w3.org/css-validator/about.html.es#what

Peroooooo.....menudo rollo.



Haz clic para ver el perfil del usuario

@man / @woman
@man / @woman

#14
Escrito originalmente por PaseanteDelForo
Escrito originalmente por k_nelita

No hay algún programa que te revise el html o códigos para saber que es lo que está mal?
http://jigsaw.w3.org/css-validator/about.html.es#what

Peroooooo.....menudo rollo.
No es rollo.... si tu generas un html correcto, estructurado, con comentarios, con tabuladores... cuando revisas y te dice un fallo, rapidamente le encuentras.
Haz clic para ver el perfil del usuario

#15
Escrito originalmente por NoSetup.org
Escrito originalmente por PaseanteDelForo
Escrito originalmente por k_nelita

No hay algún programa que te revise el html o códigos para saber que es lo que está mal?
http://jigsaw.w3.org/css-validator/about.html.es#what

Peroooooo.....menudo rollo.
No es rollo.... si tu generas un html correcto, estructurado, con comentarios, con tabuladores... cuando revisas y te dice un fallo, rapidamente le encuentras.
Ya, pero cuando ya has hecho cienmil pijadas con el codigo de la plantilla, los errores suman cientos, y corregirlos tela....

Lo tengo en tareas pendientes.... y lo hare, por mis www



Haz clic para ver el perfil del usuario

@man / @woman
@man / @woman

#16

Pero nadie hace cienmil pijadas... ni siquiera dos.

Se hace una pijada y después otra y otra... si las pijadas las haces bien....

Haz clic para ver el perfil del usuario

Foro por via intravenosa
Foro por via intravenosa

#17

Vaya con la palabrita que se han elegido, si supieran lo que quiere decir eso en Argentina...
Por lo que veo te refieres a un efecto dominó no NoSetup?
Bueno yo de momento he corregido todo (creo) gracias a la ayuda de pacosombreday, milllll gracias!! paco, es muy largo tu nick
Si a paseante le parece difícil ese programa, no quiero imaginar para mi, así que de momento paso, seguiré metiendo las manos o pezuñas en los códigos y haciendo los estragos que hago, que voy a hacerle
NoSetup no te olvides que nosotros somos seres normales con muuuuuchos defectos y pocas virtudes al menos en lo que a códigos se refiere.
No todos somos como vos Genio (de otro mundo) ja ja (es broma)

Haz clic para ver el perfil del usuario

#18
Escrito originalmente por NoSetup.org
Pero nadie hace cienmil pijadas... ni siquiera dos.

Se hace una pijada y después otra y otra... si las pijadas las haces bien....
Ya! Pero las pijadas se hacen con el p..., y ya sabes lo que dicen que con buena p...... bien se f...... .
Pues eso, saber hacerlo es facil para quien domina el html, pero para los que no lo dominamos, ....pues se hace mas durillo.





ATENCIÓN: Este tema no tiene actividad desde hace más de 6 MESES,
te recomendamos abrir un nuevo tema en lugar de responder al actual
Opciones:
Suscribir

Permisos:

TU NO PUEDES Escribir nuevos temas en este foro
TU NO PUEDES Responder a los temas en este foro
TU NO PUEDES Editar tus propios mensajes en este foro
TU NO PUEDES Borrar tus propios mensajes en este foro

Ahora son las 00:38 UTC+02:00 DST

Ir al subforo: 

Temas similares
TemaUsuariosRespuestasVisitasActividad
1716May/09
162kOct/07
1626Jul/12
7730Apr/12
0630Feb/12